OM med flera villkor i Excel

En frågeställning som vi ofta ser på vårt Excel-forum och även ofta får frågor om på våra utbildningar, är hur man med hjälp av en OM-formel kan styra vilket resultat man ska få utifrån flera villkor. Ett smidigt sätt att lösa detta är att kombinera funktionen OM med någon av funktionerna OCH/ELLER i en nästlad formel.

Om man vill att alla villkor ska vara uppfyllda använder man funktionen OCH, men om det räcker med att minst ett villkor är uppfyllt använder man istället funktionen ELLER.

Om vi t.ex. tänker oss att vi vill kontrollera om vi uppnått ett visst försäljningsmål för någon produkt, så låt oss kika på exemplet nedan där målvärdet i cell G2 är 500 000 kr.

OCH

Om vi vill få resultatet ”Mål uppnått” endast om målet uppnåtts alla månader, används formeln:
=OM(OCH(B2>=G2;C2>=G2;D2>=G2;E2>=G2);"Mål uppnått";"Mål ej uppnått")
Om någon av månadernas resultat understiger målvärdet, visas texten ”Mål ej uppnått”.

ELLER

Om vi istället vill få resultatet ”Mål uppnått” om målet uppnåtts endast någon av månaderna, används istället formeln:
=OM(ELLER(B2>=G2;C2>=G2;D2>=G2;E2>=G2);"Mål uppnått";"Mål ej uppnått")
Endast om alla månadernas resultat understiger målvärdet, visas då texten ”Mål ej uppnått”.

Ett urval av kunder som använder våra tjänster

Visa fler

Bli kontaktad av oss

Fyll i formuläret så kontaktar vi dig